CVE-2011-3342 (vulnerable 0.1.0 - fixed 1.1.3)

Short description: Buffer overflows in savegame loading

Official CVE-2011-3342 entry at

Related bug reports:

Related commits:

Patches: (sometimes more fuzz is needed to apply them)

In multiple places indices in savegames are not properly validated that allow (remote) attackers to cause a denial of service (crash) and possibly execute arbitrary code via unspecified vectors.

The bug is exploitable by passing someone a modified savegame, be it via a file sharing site, or by running a server. In case of the server the user only has to be able to login into the server, which is easy to accomplish: set no server password and do not ban anyone. Then upon joining the server the savegame will be downloaded and subsequently loaded.

Note that versions before 0.5.0 are vulnerable as well. However, these versions are over five years old and not supported anymore. Therefore no patches for earlier versions are provided. Before 0.3.5 it is not possible to exploit this bug via the internet as multiplayer over internet did not exist yet.